System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Degraded service For Player Services
Incident Report for PlayFab
Resolved
Degraded experience for a subset of titles starting at 9:25 AM PST. Up to 50% Internal Server Errors - We are investigating the cause.
Update: 10:05 AM PST service back to fully operational.
Posted Sep 17, 2021 - 09:30 PDT