Leaderboard Update Delays
Incident Report for PlayFab
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 12, 2017 - 13:11 PST
Identified
We have identified the cause for this issue, and are in the process of updating to resolve it.
Posted 8 months ago. Nov 12, 2017 - 09:56 PST