Player Search Not Available and Player Bulk Segmentation Delayed
Incident Report for PlayFab
Resolved
The incident has been resolved all data has been backfilled.
Posted about 2 months ago. Oct 24, 2018 - 16:47 PDT
Update
We continue to backfill data for PlayerSearch in Game Manager and in the Admin APIs. No Player data has been lost but you will still experience the following issues until the backfill is complete:
1) Game Manager Player Segments and Server/Admin GetPlayersInSegment APIs will return inconsistent
results of players in those segments. The returned results are optimized towards players that made most
recent changes.
2) Game Manager is displaying the wrong number of players in segments but the list of players returned is
correct.
Posted about 2 months ago. Oct 23, 2018 - 20:05 PDT
Monitoring
Additional capacity has been deployed. Bulk segments are fully operational.
Game Manager Player Search and Server/Admin GetPlayersInSegment APIs will return inconsistent results (optimized towards players that made most recent changes) as the capacity and indexes come online.
Posted about 2 months ago. Oct 18, 2018 - 20:54 PDT
Update
The issue has been identified and we are currently bringing up additional capacity to restore Player Search functionality.
Posted about 2 months ago. Oct 18, 2018 - 16:02 PDT
Update
Player Search is unavailable for all titles/players at this time. We are continuing to work on a fix for this issue.
Posted about 2 months ago. Oct 18, 2018 - 12:08 PDT
Identified
We have identified the cause for this issue, and are in the process of updating to resolve it.
Posted about 2 months ago. Oct 18, 2018 - 11:45 PDT
This incident affected: Game Manager (Player Search) and API (Admin).