System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Increased Error Rates for RedeemPlaystationStoreInventoryItems, ConsumePS5Entitlements, and ConsumePSNEntitlements APIs

Incident Report for PlayFab

Postmortem

On October 9th, 2025, between 12:20 PM and 2:40 PM PDT, some customers experienced increased failures when accessing the GameClient/ConsumePS5Entitlements and GameClient/ConsumePSNEntitlements APIs, as well as a few related APIs. The incident was caused by an outage in a third-party dependency, which resulted in our APIs receiving increased exceptions and errors. The issue was resolved once the external outage ended and normal service resumed.

Impact

Customers were unable to successfully complete requests through affected entitlements APIs for approximately two hours. This resulted in failed attempts to consume entitlements, impacting the user experience for games relying on these APIs.

Root Cause Analysis

The root cause of the incident was an external issue: a service outage in a third-party dependency. As our APIs depend on calls to the external service for authentication and entitlement verification, the outage led to increased exceptions and errors being returned to our services.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

  • Enhanced our monitoring and alerting systems to provide earlier detection of external partner outages affecting entitlements APIs.

  • Reviewed and improved our exception handling and error messaging to ensure clear communication to customers when third-party outages impact API availability.

Posted Oct 14, 2025 - 15:01 PDT

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 14:40 PDT

Update

We are continuing to investigate this issue.
Posted Oct 09, 2025 - 13:00 PDT

Investigating

We are observing increased Error Rates for RedeemPlaystationStoreInventoryItems, ConsumePS5Entitlements, and ConsumePSNEntitlements APIs
Posted Oct 09, 2025 - 12:55 PDT