System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Increased API Error Response Rate for Redemption
Incident Report for PlayFab
Postmortem

On November 11th, 2024, between 4:30 PM and 6:30 PM PST, some customers experienced a high rate of internal server errors when accessing PlayFab's Inventory/Redeem APIs. The incident was caused by a new deployment that introduced a code defect, resulting in increased 500 error responses. We resolved the issue by rolling back the deployment.

Root Cause Analysis

The root cause of the incident was a human error in the code, where an incorrect config was deployed leading to new Redeem API errors.

Action Items

·       To prevent similar incidents from happening again, we improved our testing and validation procedures

Posted Nov 19, 2024 - 15:18 PST

Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 18:57 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2024 - 18:03 PST
Identified
Most Redeem APIs for Economy V2 have been affected due a recent deployment and present degraded performance. We have identified the issue and are currently rolling out a fix.
Posted Nov 11, 2024 - 16:28 PST
This incident affected: API (Economy (V2), Inventory).