System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Audit Logs are not being collected

Incident Report for PlayFab

Postmortem

On June 4, 2025, between 17:20 and 21:11 UTC, some customers experienced issues where audit log entries were not being recorded in PlayFab. The incident was caused by the audit log database reaching its storage limit due to an internal process that rapidly updated ban records for players with many expired bans. We resolved the issue by increasing the size of the audit log database and implemented a fix to remove the functionality that triggered these high-speed updates.

Impact

During the impact period, audit log entries were not recorded. While it is unclear if customers were unable to use the Audit History page, the lack of recorded entries could have affected visibility into recent account activity.

Root Cause Analysis

The issue arose because Game Manager, while loading player bans, marked expired bans as inactive. For one studio, this rapid process filled the audit log database to its maximum size.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

·       We removed the functionality where Game Manager sets expired bans as inactive during player ban list loading, to avoid rapid bulk updates.

·       We increased the storage capacity of the audit log database to mitigate immediate risk.

·       We have proposed the creation of an alert to notify the team when database utilization reaches 80%.

Posted Jun 18, 2025 - 11:27 PDT

Resolved

The issue is now resolved. Audit log are fully functional.
Posted Jun 04, 2025 - 21:10 PDT

Investigating

We are investigating an issue in Audit log persistance.
Posted Jun 04, 2025 - 18:43 PDT
This incident affected: Game Manager (Console).