System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Elevated API latency

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 19:52 PDT

Monitoring

We have completed re-routing traffic from the affected compute cluster, and API latencies are returning to normal.
Posted Jun 23, 2026 - 19:08 PDT

Identified

We have identified an issue causing increased API latency in one of the compute clusters and are re-routing traffic to mitigate the issue.
Posted Jun 23, 2026 - 18:52 PDT

Investigating

We are currently investigating elevated latencies affecting a portion of API requests, across all APIs.
Posted Jun 23, 2026 - 18:02 PDT
This incident affected: API (Authentication, Cloud Script, Content, Data, Economy (V2), Events, Inventory, Lobby, Matchmaking, Statistics and Leaderboards).