System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Increased error rates for multple Economy V2 APIs, increased delayed for PlayStream events, and increased delay for maketplace APIs

Incident Report for PlayFab

Postmortem

On January 8th, 2025, between 5:30 PM and 9:02 PM PST, some customers experienced delayed playstream processing and increased error rates for economy requests when accessing PlayFab's API. The incident was caused by network connectivity issues from backend services. We resolved the issue by migrating traffic to a health backend.

Impact

The incident resulted in delayed playstream processing and increased error rates for economy requests. Additionally, the Economy V2 SLA dipped to 99% reliability during the impact period.

Root Cause Analysis

The root cause of the incident was identified as network connectivity errors from a specific backend. The connectivity issues were not caused by any recent changes.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

·       Enhanced our monitoring and alerting systems to detect and report any anomalies in the load balancer's behavior and performance.

·       Automatic failure when backend services are impacted

Posted Feb 04, 2025 - 13:09 PST

Resolved

This incident has been resolved.
Posted Jan 08, 2025 - 21:02 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2025 - 19:47 PST

Investigating

Issue is under investigation.
Multiple Economy APIs have degraded performance, including Inventory APIs, redemption APIs and PlayStream for Economy
Posted Jan 08, 2025 - 18:43 PST
This incident affected: PlayStream (Event Processing) and API (Economy (V2), Inventory).