System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Increase in GetMatchmakingTicket errors
Incident Report for PlayFab
Postmortem

What Happened:
A title launch increased Matchmaking's total traffic by ten times. The unexpected increase in load caused not only failures to clients but also had ripple effect on internal components.

Mitigation:
We continued to scale out our resources over the course of the week until we were able to safely handle the volume. We also spent time working with the customer to help significantly reduce their calling patterns to Matchmaking.

Next Steps:
To ensure we are able to scale to unexpected traffic like this in future, we have added items to our backlog. The overall requests are back to earlier load now. We will be scaling back down our services to reduce our COGs - this may result in some periodic issues, but they will be resolved shortly.

Posted Apr 20, 2021 - 14:36 PDT

Resolved
The services have fully recovered.
Posted Apr 01, 2021 - 17:59 PDT
Investigating
We are continuing to investigate the issue as the DNS Outage begins to recover
Posted Apr 01, 2021 - 16:55 PDT
Update
We are continuing to scale out our services, but it isn't helping as we expected, so we are continuing to investigate.
Posted Apr 01, 2021 - 14:09 PDT
Update
We are continuing to wait for services to scale up.
Posted Apr 01, 2021 - 13:30 PDT
Update
We have identified the significant increase in call volume was due to a recent title launch. We have temporarily moved the launch title over to a different vertical so it doesn't affect the remaining titles. We are continuing to scale up the services to meet the demand.
Posted Apr 01, 2021 - 12:17 PDT
Identified
Some titles might be experiencing an increased amount of failures when trying to call GetMatchmakingTicket. We have identified higher call volumes, and are scaling up our services to meet the demand.
Posted Apr 01, 2021 - 11:21 PDT
This incident affected: API (Matchmaking).