System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Event delays

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 09:12 PDT

Monitoring

A fix has been deployed and we're monitoring the status.
Posted May 31, 2026 - 07:31 PDT

Investigating

All PlayFab events are currently delayed and the team is investigating
Posted May 30, 2026 - 13:33 PDT
This incident affected: PlayStream (Event Processing) and API (Events).