System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Reports are delayed for May 21st

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted May 22, 2025 - 15:23 PDT

Investigating

We are currently investigating an issue with processing analytics reports and daily title report emails for May 21st.
Posted May 22, 2025 - 11:33 PDT