System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Degraded API availability for GetPlayersInSegment API
Incident Report for PlayFab
Postmortem

On April 4th, 2024, between 5:21 AM and 4:28 PM PDT, some customers experienced a partial outage of GetPlayersInSegment API. The incident was caused by an expired credential. We resolved the issue by generating a new credential and deploying the changes to the affected regions. 

Action Items 

  • We improved our documentation and communication procedures for updating credentials to ensure that all are updated correctly and timely. 

  • We enhanced our monitoring and alerting systems to detect and report any errors related to credential expiration or access denial. 

  • We are prioritizing the deprecation process of GetPlayersInSegment API and encouraging customers to use the ExportPlayersInSegment and GetSegmentExport APIs instead.

Posted Apr 23, 2024 - 17:13 PDT

Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 16:57 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 04, 2024 - 09:46 PDT
Identified
We are still seeing degraded API availability and are working on a fix.
Posted Apr 04, 2024 - 06:11 PDT