System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Multiplayer servers have an outage in East US region due to problems with Azure Batch
Incident Report for PlayFab
Resolved
Azure outage has been mitigated.
Posted Oct 28, 2020 - 21:43 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 28, 2020 - 13:50 PDT