System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Drop in availability for Client/LoginWith[Platform] APIs

Incident Report for PlayFab

Postmortem

On February 17, 2026, between approximately 10:00 AM and 11:14 AM Pacific Time, some customers experienced increased failures when calling the Client/LoginWith[Platform] APIs. The issue was caused by a code regression that inadvertently removed a required validation check, leading to internal server errors. We mitigated the issue by rolling back the update.

Impact

During the impact window, customers experienced failed login attempts through the Client/LoginWith[Platform] APIs, with availability dropping to as low as 93%.

Root Cause Analysis

A recent code change removed a necessary null check, which caused certain requests for these APIs to fail.

Action Items

Rolled back the service update to immediately restore API availability.

Deployed a hotfix to correct the code regression. Tests were also added to prevent this issue from recurring.

Posted Feb 24, 2026 - 14:42 PST

Resolved

We observed a spike in errors affecting all Client/LoginWith[Platform] APIs. This was caused by a production deployment that was reverted.
Posted Feb 17, 2026 - 09:00 PST