System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Reduced API availability

Incident Report for PlayFab

Postmortem

On January 22, 2025, between 10:44 AM and 11:15 AM PST, some customers experienced increased latency in PlayFab's API. The incident was caused by a network configuration issue during the migration to new Redis instances, which resulted in ports being blocked. We resolved the issue by rolling back to the previous Redis cluster and restarting the pods.

Impact

The APIs experienced increased latency; however, the availability remained above the Service Level Objective (SLO).

Root Cause Analysis

The issue was caused by the migration to new Redis instances, which resulted in the use of ports that were not included in the exclusion list.

The issue was not detected sooner because the alert was set as severity 4 and was not noticed immediately. Availability numbers were not impacted by the change.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

·       Exclude the full range of Redis ports.

·       Improved our testing and validation procedures for network configuration changes to catch such issues before they reach production.

·       Improved deployment process of infrastructure changes by rolling out updates to a subset of users

Posted Feb 11, 2025 - 14:24 PST

Resolved

This incident has been resolved yesterday afternoon. Apologies for the late update.
Posted Jan 23, 2025 - 08:00 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2025 - 13:14 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 22, 2025 - 13:14 PST

Investigating

Customers are experiencing reduction in API availability and increased latency since an infrastructure upgrade. We are investigating and preparing to roll back the infrastructure change.
Posted Jan 22, 2025 - 12:40 PST
This incident affected: API (Authentication, Cloud Script, Content, Data, Economy (V2), Events, Inventory, Lobby, Matchmaking, Statistics and Leaderboards).