System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Economy v2 Steam integration
Incident Report for PlayFab
Postmortem

On August 19th, 2024, between 10:44 PM PDT and August 21st, 2024, 02:00 AM PDT, some customers experienced failures when attempting to purchase items on Steam. The incident was caused by a code defect in the Steam Redeem API integration, which returned incorrect responses. We resolved the issue by rolling back the deployment to the previous stable version.

Root Cause Analysis

The root cause of this incident was a code defect in the Steam Redeem API integration. Null safety was added to all marketplace handlers to return a no-op (200) if response bodies were null. This resulted in an incorrect 200 response being returned instead of a failure alert.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

  • Fixed the error (500) on redemption mapping to no-op success (200) in inventory.

  • Added monitoring for IAP success rate per marketplace.

Posted Sep 04, 2024 - 12:39 PDT

Resolved
This incident has been resolved.
Posted Aug 21, 2024 - 02:11 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2024 - 02:06 PDT
Investigating
Our engineering teams are investigating issues preventing purchases of Economy v2 catalog items in Steam.
Posted Aug 21, 2024 - 01:59 PDT
This incident affected: Add-ons (Steam).