System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Billing Summary - Most recent daily bill estimate may be slow to populate

Incident Report for PlayFab

Postmortem

On January 18, 2026, between approximately 6:00 PM and 10:45 PM PT, some customers experienced delayed updates in the PlayFab Billing Summary report. The issue was triggered by a change in an external data query dependency, and service was restored after a hotfix was deployed and the processing pipelines were re-run.

Impact

The daily Billing Summary update (including the “last updated” timestamp, daily CSV, and refreshed month-to-date estimates) was delayed by roughly 4.5 hours. Customers viewing Billing Summary during that window may have seen estimates that were older than expected.

Root Cause Analysis

An external partner change introduced a new required parameter for a data update operation used by our billing reporting pipeline. This caused part of the daily aggregation and update flow to fail until we adjusted the operation and reprocessed the affected data.

Action Items

To prevent similar incidents from happening again, we are taking the following actions:

  • Improving our monitoring process to more quickly detect failures in the end-to-end billing update flow so delays can be identified and addressed sooner.
  • Investigating improvements to communication with external dependency team for upcoming changes on their end
Posted Jan 28, 2026 - 09:16 PST

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 01:45 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2026 - 23:00 PST

Investigating

Billing Summary daily bill estimates may not contain the most recent day's estimate. We are currently investigating this issue, and expect to populate all daily billing estimates in the summary when the issue is resolved
Posted Jan 18, 2026 - 18:15 PST
This incident affected: Analytics (Reports).