System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Intermittent API failures in Leaderboard, Lobby and Game Saves services

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 17:18 PST

Monitoring

A fix has been deployed (4:35PM PST) and failure rates are quickly returning to normal. We are continuing to monitor.
Posted Nov 25, 2025 - 17:06 PST

Investigating

PlayFab APIs are experiencing intermittent failures in Leaderboard, Lobby and Game Saves services due to failures in an underlying infrastructure dependency. API success rates in these spaces are between 80-100%, with retries leading to success. Failures will manifest as 4XX and 5XX errors.
Posted Nov 25, 2025 - 16:53 PST
This incident affected: API (Lobby, Statistics and Leaderboards).