System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

PlayStream and Telemetry Event Delivery Delay

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 15:11 PDT

Monitoring

A fix has been deployed and we are monitoring the results.
Posted Aug 14, 2025 - 14:52 PDT

Identified

We have identified the issue and are working on a fix.
Posted Aug 14, 2025 - 14:45 PDT

Investigating

We are currently experiencing an issue in our data delivery pipeline. Customers may notice a delay in events appearing via Data Explorer or in Data Connections. Real-time processing of PlayStream events (e.g. for Automation Rules or WebHooks) is also impacted.

No data has been lost and engineers are working to resolve this as soon as possible.
Posted Aug 14, 2025 - 14:15 PDT
This incident affected: PlayStream (Data Connections) and Analytics (Event History & Search).