System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Delayed event ingestion for Data Explorer basic and advanced.

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted May 19, 2026 - 20:16 PDT

Monitoring

An issue has been fixed that was causing ingestion delays for event data to the Data Explorer features in Game Manager. Approximately 25% of titles may have been impacted with up to a 40 minute delay. The issue has been addressed and we are monitoring the ingestion delay recovery.
Posted May 19, 2026 - 18:05 PDT
This incident affected: Analytics (Event History & Search).