System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Economy v1 Game Manager pages not loading

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted May 06, 2025 - 15:20 PDT

Identified

We're aware of the problem and are working on a fix
Posted May 06, 2025 - 13:27 PDT
This incident affected: Game Manager (Console).