System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Elevated API latency and connection failures

Incident Report for PlayFab

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 15:30 PDT

Monitoring

A change to API request routing has caused a temporary increase in API latency and connection errors. We have deployed a change to mitigate the impact, and we are observing a return to normal latencies.
Posted Mar 24, 2026 - 13:05 PDT