Microsoft Azure PlayFab

System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Multiplayer Servers - Management APIs and server allocation are malfunctioning
Incident Report for PlayFab
Postmortem

Networking issues in West US impacting PlayFab’s ability to deploy multiplayer server builds to this Azure region.

PlayFab control systems had several areas where we would check deployment status in all regions, these codepaths had performance issues during the West US incident impacting Game Manager load time.

We will be improving the resiliency of these operations to single-region failure.

Posted 6 months ago. Feb 12, 2019 - 13:53 PST

Resolved
This incident has been resolved.
Posted 7 months ago. Jan 29, 2019 - 21:06 PST
Update
PlayFab services are having challenges communicating with critical Azure resources. This impacts management and allocation of multiplayer servers. We believe this is related to on-going Azure West US network issues and exacerbated by cascading issues from the earlier Azure network infrastructure event, but this has not been confirmed. Mitigations are being deployed immediately while we work with Azure to rectify the issue ASAP.
Posted 7 months ago. Jan 29, 2019 - 20:03 PST
Update
Issues are impacting server allocation as well.
Posted 7 months ago. Jan 29, 2019 - 19:25 PST
Update
We are continuing to investigate the issue.
Posted 7 months ago. Jan 29, 2019 - 19:24 PST
Investigating
Multiplayer Server pages in Game Manager may be missing builds and otherwise error. We are investigating.
Posted 7 months ago. Jan 29, 2019 - 19:15 PST
This incident affected: Multiplayer Game Servers 2.0 (Request Multiplayer Server API, Build Management - Game Manager and APIs).