System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Delayed processing of player deletes

Incident Report for PlayFab

Postmortem

Starting on August 6th around 21:00 UTC, the processing of master player account deletion requests was delayed across multiple titles. Some players experienced an error message when trying to recreate their account while it was pending deletion. This incident was caused by a recent code change. We resolved the issue by reverting the code change, which enabled the pending deletes to complete. The incident was resolved on August 9th at 22:26 UTC.

Impact

  • Delayed processing of master player account deletions.
  • Some players trying to recreate or re-register their accounts were blocked with an error message stating, "The account is unavailable because it’s being deleted" during the incident time.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

  • Improvements to our development and testing processes
Posted Aug 21, 2024 - 12:56 PDT

Resolved

This incident has been resolved.
Posted Aug 12, 2024 - 08:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 09, 2024 - 14:03 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 09, 2024 - 12:25 PDT

Investigating

Our engineering teams are investigating the delayed processing of player deletes since August 6, 21:00 UTC. The list of affected APIs is:
Admin/DeleteMasterPlayerAccount, Admin/DeletePlayer, Admin/DeleteMasterPlayerEventData
Posted Aug 09, 2024 - 11:46 PDT