System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Data from Insights S3 Exports is delayed
Incident Report for PlayFab
Postmortem

Starting on 2024-10-29 at 19:15 UTC until 2024-10-30 18:15 UTC, some customers experienced delays in data exports to S3.  This incident was caused by a misconfiguration in API routing that impacted the export service. The issue was resolved by correcting the configuration used for API routing.

Impact

All Insights data exports to S3 were delayed due to errors in the export service. There was no data loss, the export service continued to retry until success. Data caught up in less than an hour after the configuration was fixed.

Root Cause Analysis

The root cause of the incident was a human error in configuration.

Action Items

To prevent similar incidents from happening again, we have taken the following actions:

·       Improved our monitoring and alerting systems to detect and report anomalies in the export service's API requests.

Posted Nov 05, 2024 - 13:46 PST

Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 11:16 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2024 - 10:29 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2024 - 09:34 PDT
Investigating
We are currently investigating delays exporting Insights data to S3. Impact started around 2024-10-29 19:00 UTC.
Posted Oct 30, 2024 - 09:32 PDT
This incident affected: Analytics (Event Archiving).