System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

PlayStream Processing Delay

Incident Report for PlayFab

Postmortem

On July 25, 2025, between 2:52 PM and 3:13 PM UTC, some customers experienced delays in PlayStream processing. The incident was caused by errors when our systems encounter partner storage service errors.  The incident was resolved when the underlying storage resource recovered.

Impact

All PlayStream processing was delayed for approximately 21 minutes. No repeated outages were reported.

Root Cause Analysis

The PlayStream processor application encountered errors while accessing a critical database. A slight increase in server-side latency was observed.

Action Items

  • Improve internal log formatting for PlayStream services to ensure exception data is more easily queryable and can be aggregated for common error analysis.
  • Enhance monitoring and alerting to better capture anomalies in PlayStream processing and database connectivity.
Posted Aug 07, 2025 - 10:55 PDT

Resolved

On July 25, there was a delay in PlayStream processing between 07:40 - 08:10 PDT (14:40 - 15:10 UTC). We have identified the cause and the service has now recovered.
Posted Jul 25, 2025 - 08:00 PDT