System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Increased API Error Rates
Incident Report for PlayFab
Postmortem

On April 11th, 2024, between 12:20 PM and 1:28 PM PDT, some customers experienced intermittent errors and delays when accessing PlayFab's API. The incident was caused by a network configuration change that triggered a bug in one of our load balancers, resulting in traffic being routed incorrectly. We resolved the issue by rolling back the configuration change and applying a patch to the load balancer. 

Action Items 

  • We improved our testing and validation procedures for network configuration changes to catch such bugs before they reach production. 

  • We enhanced our monitoring and alerting systems to detect and report any anomalies in the load balancer's behavior and performance. 

  • We updated our documentation and training materials to ensure that our engineers are aware of the potential impact of making network configuration changes.

Posted May 01, 2024 - 11:46 PDT

Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 13:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2024 - 13:34 PDT
Update
We are continuing to investigate this issue.
Posted Apr 11, 2024 - 13:12 PDT
Investigating
We are currently investigating this issue.
Posted Apr 11, 2024 - 13:06 PDT
This incident affected: API (Authentication, Cloud Script, Lobby, Matchmaking).