System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Issues loading the Upgrade Account / Plan Recommendation page

Incident Report for PlayFab

Postmortem

On November 23rd–24th, 2025, some customers experienced errors when using PlayFab’s Plan Recommendation and Pricing Sync features. The incident was caused by an authentication issue in a billing service component, which disrupted several related services. We resolved the issue by updating the connection logic for our data service.

Impact

Customers were unable to access plan recommendations and update workflows. The issue was detected by our monitoring systems and reported by customers.

Root Cause Analysis

The authentication errors were triggered by changes in the underlying .Net version, which affected how a billing service component connected to our data service.

Resolution

We updated the connection logic for the billing service component, restoring normal operation and notifying affected customers.

Action Items

  • Improved the connection logic for our data service in the affected billing service component.

  • Enhanced monitoring to detect authentication issues earlier.

Posted Jan 09, 2026 - 15:52 PST

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 15:25 PST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 11:37 PST

Investigating

We are investigating failures causing the Upgrade Account / Plan Recommendation page to not load properly.
Posted Nov 24, 2025 - 11:37 PST