System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
We are investigating API degradation for Cloudscript APIs
Incident Report for PlayFab
Postmortem

On April 10th, 2024, between 10:30 AM and 11:15 AM UTC, some customers experienced intermittent errors and delays when accessing PlayFab's API. The incident was caused by a code change that caused servers to operate in the wrong environment. We resolved the issue by manually updating DNS records and pointing to the correct cluster. 

Action Items 

  • We improved our testing and validation procedures for deployments to catch such bugs before they reach production. 

  • We enhanced our monitoring and alerting systems to detect and report any anomalies in the server’s behavior and performance.

Posted May 02, 2024 - 11:56 PDT

Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 11:30 PDT
Identified
Our team has identified the issue and services are recovering.
Posted Apr 10, 2024 - 11:23 PDT
Investigating
We are currently investigating this issue.
Posted Apr 10, 2024 - 10:51 PDT
This incident affected: API (Cloud Script).