System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

A subset of catalog items created since October 21st have been unable to be redeemed

Incident Report for PlayFab

Postmortem

Incident Overview 

Between October 21st, 2025, and December 3rd, 2025, users were unable to redeem a subset of marketplace purchases for catalog items created during this window. The incident was caused by a misconfiguration affecting a redemption processor that prevented a subset of newly created items from being available for redemption. The issue was resolved by fixing the misconfiguration.   

Impact 

Users were unable to redeem a subset (3-4%) of items that were created during the window. All purchases made during this period have been redeemable since the fix on December 3rd. 

Action Items 

To prevent similar incidents from happening again, we have taken the following actions: 

  • Additional validation to avoid misconfigurations affecting the redemption processing system 

  • Enhanced alerting for the redemption processor to improve detection of similar issues

Posted Dec 18, 2025 - 15:06 PST

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 09:51 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 03, 2025 - 14:02 PST
This incident affected: API (Economy (V2)).