System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage
Incomplete Title Overview data in Game Manager
Incident Report for PlayFab
Resolved
The incident has been resolved; dashboards now load as expected.
Posted Oct 24, 2024 - 14:27 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2024 - 16:04 PDT
Investigating
We are currently investigating an issue that is preventing some data from loading in the Title Overview page in Game Manager.
Posted Oct 22, 2024 - 12:00 PDT
This incident affected: Analytics (Dashboard).