System Status

Status of PlayFab services and history of incidents

Operational
Partial Outage
Major Outage

Increased Error Rates for PSN APIs

Incident Report for PlayFab

Postmortem

On February 7th, 2025, between 3:15 PM PST and 3:00 PM PST on February 8th, 2025, some customers experienced increased latency and intermittent failures when making PlayStation network-related calls (e.g., LoginWithPSN, RedeemPlayStationStoreInventoryItems) on PlayFab's service. The incident was caused by a PlayStation Network outage leading to a high rate of InternalServerErrors for API calls dependent on the PlayStation Network. We monitored the situation and the issue was resolved once the PlayStation Network recovered.

Impact

All PlayStation Network-related API calls experienced increased latency and an intermittent failure rate over the course of 24 hours. This incident impacted the overall availability SLA for PlayStation-related services during this period.

Root Cause Analysis

The root cause of this incident was an external issue with the PlayStation Network. The PlayStation Network outage was outside of our direct control and required intervention from PlayStation to resolve.

Action Items

• Improve our communication protocols with partners to receive timely updates on outages and recovery status.
• Enhance monitoring and alerting systems to detect and report anomalies in a more granular manner for external dependencies.

Posted Feb 19, 2025 - 16:10 PST

Resolved

This incident has been resolved.
Posted Feb 08, 2025 - 15:00 PST

Identified

We are observing increased errors for PSN APIs because of a third party outage and are currently monitoring.
Posted Feb 07, 2025 - 16:23 PST

Investigating

We are observing increased errors for the LoginWithPSN APIs because of a third party outage and are currently monitoring.
Posted Feb 07, 2025 - 15:00 PST
This incident affected: API (Authentication).